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Introduction

To assist our customers GRAPHISOFT have developed a new ARCHICAD add-on that
simplifies and streamlines the interoperability workflow.

The Survey Coordinate Tool aims to provide a help with the focus on solving project
coordinate location translation. The add-on creates a data driven approach that allows
correct and precise translation of coordinates between ARCHICAD and other BIM authoring
tools. This strongly complements GRAPHISOFT's approach to Open BIM initiatives and
workflows.

Installation
Note: XX =23 or 24

Windows

ARCHICAD XX

Download the Updated Survey Coordinates Add-On via (UAS Exclusive Downloads - Tools
section) and unpack the Add-On from the .zip folder (UpdateSurveyCoordinates.apx and
en)

Navigate to the Add-Ons folder of where ARCHICAD has been installed. By default, the
location is C:\Program Files\GRAPHISOFT\ARCHICAD XX\Add-Ons

Drag and drop the UpdateSurveyCoordinates.apx and en we unpacked in step one and
drop it into the Add-Ons folder

Mac

ARCHICAD XX

Download the Updated Survey Coordinates Add-On via (UAS Exclusive Downloads - Tools
section) and unpack the Add-On from the .zip folder (UpdateSurveyCoordinates.bundle)
Navigate to the Add-Ons folder of where ARCHICAD has been installed. By default, the
location is Macintosh HD/Applications/GRAPHISOFT/ARCHICAD XX/Add-Ons

Drag and drop the UpdateSurveyCoordinates.bundle we unpacked in step one and drop it
into the Add-Ons folder
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After the Add-On has been installed you should find the following:
In the Options Menu a new command called Updated Survey Coordinate Objects.

fA Untitled - ARCHICAD 23

File Edit View Design Document Options Teamwork Window Twinmotion

) J‘ O\ A IR DR Element Attributes » |
Main: Layer ‘@ Property Manager...
|Defammmgs ' Ij mil py & Classification Manager... |
- ' Complex Profiles 4
N 88 ["5) GF-Ground Floor [0. G Auto Intersection J;
- | Update Survey Coordinate Objects |
Design @ Add-On Manager...
D Project Preferences 4
B Work Environment »

And a new object called Survey Coordinate Object which is in the Object tool, Built-In
Libraries > UpdateSurveyCoordinates folder.
Rl Y Q| &

Embedded Library
> Linked Libraries

BIMcloud Libraries
v [ Built-in Libraries

> B BuiltintibraryParts.Icf

. GoogleEarthConnectivity.apx

B 1Fc.apx

- UpdateSurveyCoordinates.apx

%

X: 20.362
Y: 8.640
Z:2.422 S

Survey Coordinate Object
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Scope and Basic Concepts

The Survey Coordinate Object has the following features:

Reads from a placed Survey Point in the model

Angle as defined in Rotate Orientation command is now considered when X/Y values
are reported

Coordinate Values (X, Y, Z) can be scheduled via an Element Schedule

Coordinates can be shown in 3D

Formatting options available (Different font types, symbol types, frames, etc)

Survey Points which are placed in hotlinks are ignored

Allows you to affectively work at 0,0,0 but still provide “real world coordinate”
information for both documentation and IFC exports
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Workflow

We will use the following coordinates below to demonstrate the setup of the Survey Point

Example

position in order to read the agreed X/Y coordinates based on a rotated orientation:
Reference Point | Grid | Easting (X) | Northing (Y) | Angle to True North
Origin N/A | 10,000 10,000 10.0000°
Grid A/ 34,037 31,147 10.0000°

Step 1 - Define orientation
Use the rotate orientation command to set the “True North” value. Based on the above
table we will need to rotate the orientation by 10.0000° degrees in order to correctly place

the Survey Point.

»

117% 'l O 350.0000°

Y OREJOREX
Image above shows the ARCHICAD model orientated by 10.0000° degrees. If the angle is
positive, you will need to rotate the orientation clockwise.
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Step 2

Positive angle to true north

Navigate to the Options Menu> Project Preferences> Project Location dialogue. In order to
generate the correct True North angle, the rule of thumb is as follows:

If the angle is positive as in the example above, then you need to add the true north angle
to 90.0000° degrees. For example, 90.0000° + 10.0000° = 100.0000°

Negative angle to true north

If the angle is negative, then in step 1 you will need to rotate the orientation anticlockwise.
Navigate to the Options Menu>Project Preferences>Project Location dialogue. In order to
generate the correct True North angle, the rule of thumb is as follows:

If the angle is negative, then you need to subtract the true north angle from 90.0000°. For
example, 90.0000° - 10.0000° = 80.0000°

Image below shows the correct Angle to True North setup as based on the example above.

B Project Location ? X
Project Name: | <PRI_NAME> | Edit..

Site Full Address: |<SITE_ADDRESS> <SITE_CITY> <SITE_COUNTY> Edit...

Latitude: [51° 30° 0.0000° v vm (@R[>
Longitude: |o= 10° 0.0000° | W v |
Time Zone (UTC): | (UTC+00:00) Dubli...h, Lisbon, London vl

Altitude (Sea Level): *'m
Project North:
/wo | 100.00° ’I
L

Note: Changing Project Location will affect the Sun
position, including in 3D Views and Cameras with Show in Google Maps...

stored Date and Time.

Step 3 - Placing Survey Point

Open the Object tool and locate the Survey Point object. By default, the Survey Point is
located within the Built-In Libraries folder followed by the IFC folder. Alternatively, you can
use the search function at the top of the Object settings dialogue and search for the
keyword “Survey” and ARCHICAD will find the Survey Point automatically.
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Screenshot below shows the default location of the Survey Point object
4

B Yr Q| | &
v Linked Libraries A

£ ARCHICAD Library 23

BIMcloud Libraries

v [ Built-in Libraries

B3 BuiltinLibraryParts.icf

E] GoogleEarthConnectivity.apx

E| IFC.apx

E] UpdateSurveyCoordinates.apx

SP :

I,

To place the Survey Point:

e Hover your cursor over ARCHICAD's origin (0,0,0) as indicated as a black X on the
floor plan.

o Press X" on your keyboard and type in the desired coordinate. Based on the table
above our X coordinate would be typed as 10000- (coordinate value followed by
minus sign “-")

e After the X coordinate has been entered press the tab key to drop down into the Y
coordinate and type in the desired coordinate. Based on the table above our Y
coordinate would be typed as 10000- (coordinate value followed by minus sign “-“)

e Press the enter key and the Survey Point object will be placed at the entered
coordinates but in relation to the orientation angle as defined in Step 1.

We recommend locking the Survey Point's layer after the Survey Point has been placed to
the desired coordinate.
After the Survey Point has been placed you can set the orientation back to 0.0000°
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Step 4 - Placing the Survey Coordinate Object

After the Survey Point is placed, we can now start to use the Survey Coordinate Object to
report the coordinates on floor plan. Open the object tool and locate the Survey Coordinate
Object and ensure that the Display Coordinates parameter is set to Survey Point Object as
shown on the screenshot below:

bject Default Settings ?
fA Object Default Setting ? X
B Yy Q| | |8 * survey Coordinate Object Default
g Embedded Library ~ D1 PREVIEW AND POSITIONING ;
Linked Libraries T F
BIMcloud Libraries [ 5
I - 2
v h Built-in Libraries Home Story: 0
B3 suittintibranyparts.ict [ 0. GF-Ground Floor (Current) | 0
GoogleEarthConnectivity.apx H -
B rrc to Project Zero [» ® Y- ©
.apx 1 .
ﬁ UpdateSurveyCoordinates.apx - Z 1 OO
Relative | »
X: 20.362 & 0 &
Y:8.640
Z:2.422 @ - CUSTOM SETTINGS
< » = R~ coordinate System and Custom Origin... »
Survey Coordinate Object
Dispiay Coordnates

|:| Show Marker in 3D
Enable Height Coordinates
(@ Display of Height Coordinates can be controlled separately in 2D and 3D.

Survey Point Object Coordinates X 0.000
Y 0.000
z 0.000
Survey Point Object Rotation Angle 0.00°

» [Z FLOOR PLAN AND SECTION
» () MoDEL
» CLASSIFICATION AND PROPERTIES

%, <@ A-Pra020--Sanitar...gsAndAccessories » Cancel

Place the Survey Coordinate Objects down onto your model. By default, the objects will
read their local coordinates from ARCHICAD's origin (0,0,0) To show the Survey Coordinate
Objects X/Y values in relation to the Survey Point navigate to the Options Menu and run the
Update Survey Coordinate Objects command.
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Survey Coordinate Object examples
The image below shows how the Survey Coordinate object will display by default when
placed onto the ARCHICAD origin (0,0,0)

-
X:0
Y:0
Z: 100

The image below shows the X/Y coordinates after the Update Survey Coordinate Objects
command is run. The X/Y coordinates are now shown in relation to the Survey Point
position.

%
X: 10,000

Y: 10,000
/: 100

The image below shows how the Survey Coordinate object will display by default when
placed at a difference location. In this instance grid intersection, A/1.

/N
1
'/
.

/
% |
\L f
o / — Gf
X:20,000- —

Y: 25,000 -
Z:100
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The image below shows the X/Y coordinates after the Update Survey Coordinate Objects
command is run. The X/Y coordinates are now shown in relation to the Survey Point
position.

—_

T

X: 34,037 —
| Y:31,147
Z:100

/

We now have the correct “Real World” coordinates shown on our model but in reality, the
ARCHICAD model is still located close to ARCHICAD's origin (0,0,0)

Step 5 - Defining Sea Level

An additional step for exporting an IFC to “Sea Level” is to enter the agreed datum into the
Survey Point object.

For example, if the agreed datum is 45,000mm the value must be entered as negative
(e.g. -45,000mm) in the elevation parameter, as shown below:

fA Object Selection Settings ? X
4
B Yy Q| | @ survey Point Selected: 1 Editable: 1
(e
q Embedded Library ~ O PREVIEW AND POSITIONING )
Linked Libraries "
0O [5132x 3357
BIMcloud Libraries
W o
v B Built-in Libraries Home Story:
itinLi : @
B suittintibraryarts.icf | 0. GF-Ground Floor (Current) | e sp X0
B3 GoogleEarthConnectivity.apx X Y:0
to Project Zero | » -
g - RV
45000
B9 updatesurveyCoordinates.apx b} R
SP i '
Relative | »
i 5 O @l
» SURVEY POINT SETTINGS
» [Z FLOOR PLAN AND SECTION
[Survey Point| » () mopEL
» CLASSIFICATION AND PROPERTIES
%, &> A-Pr4020--Sanitar...gsAndAccessories » Cancel
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How to schedule the X/Y/Z coordinates
Create an element schedule then set the criteria to Element Type is Object, add another
criterion and set it to Library Part Name is Survey Coordinate Object.
Screenshot below shows the criteria added to the element schedule. The criteria above will
schedule only objects which have the library part name of “Survey Coordinate Object”

v CRITERIA / NEW SCHEME

( Criteria Value ) and/or
= Element Type is aa Object and
= Library Part Name is Survey Coordinate Object
Add Criteria... v Remove

In the subheading fields click on the arrow next to Add Fields followed by Library Part
Parameters as shown on the screenshot below.

v FIELDS / NEW SCHEME
Name DAV

I Add Fields... v | Remove

Parameters & Properties...
Cancel oK

| Library Part Parameters...
IFC Properties...
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In the Additional Object Parameters dialogue, set the Select Object By drop down menu to

Folder View (used Objects only) Open the folder called UpdateSurveyCoordinates, then

select the Survey Coordinate Object.gsm

On the left locate the following parameters:
Custom Coordinate X
Custom Coordinate Y
Custom Coordinate Z

Select all three parameters above and click the Add button below to add them to the

schedule.

fA Additional Object Parameters

Folder View (used Objects only) v

Select Object by:
v IFC.apx
Bn Survey Point.gsm
Grid Tool.apx

v UpdateSurveyCoordinates.apx

Hn Survey Coordinate Object.gsm

Available Parameters:

Selected Parameters:

Variable Type Name A Variable o Type
fontSizeCoor_pt -¥ Coordinates Font Size A CustomCoordX §3
fontCoorMat 5 Coordinates Font Surface CustomCoordY &3
bltalicCoor B  Coordinates Italic CustomCoordZ &3

bUnderlinedC... B Coordinates Underlined

fontSizeCustO...
fontSizeCustO...
<

istom Orinin Fant Size

Custom Origin Bold

Custom Origin Font Pen
. $3  Custom Origin Font Size
Custom Origin Font Size

>>Add>> Remove

Name

Custom Coordinate X
Custom Coordinate ¥
Custom Coordinate Z

After the Custom Coordinate X, Y and Z parameters have been added to the schedule you
should see the following result:

o

o

[ )

. 1 . . . .
| 100

Coordinate Schedule

Custom Coordinate X

Custom Coordinate Y

Custom Coordinate Z

10,000

10,000

45,000

34,037

31,147

45,000
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Working with Surveys

The above workflow is mainly for setting up a model which will be exchanged between
different disciplines via IFC.

If you require to show coordinates in relation to an imported survey but you are not issuing
an IFC file, then the steps are a little different as shown below.

Step 1 - Import the Survey
Place the Survey Drawing via the File Menu>External Content>Place External Drawing
command.
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Step 2 - Defining the origin point

Surveys are normally already orientated to their True North value, therefore in this case we
do not need to use the rotate orientation command to place the Survey Point.

We do however need to choose a known point on site we would like to reference to. In the
Survey | imported there are two station points as highlighted above in step 1.

Station Point A:

X: 250978.895 metres

Y: 386238.688 metres

Station Point B:

X: 250986.919 metres

Y: 3860272.885 metres

In this example Il use Station Point A as my reference. Therefore, we need to drag the
imported survey by Station Point A and place it onto the ARCHICAD origin (0,0,0)
Screenshot below shows Station Pugint A placed onto ARCHICAD's origin (0,0,0)

1C
1.54% \
21 \ 21.46(%) i 20-77
' ‘ 0-94
| \
\ \
2146 | 21-40 o
) V ) '
1 ' (= '
2 S ool
= [EERE> AT | \ A -
; o 1T et © A -
= 3o - R )’&,
= e * = AT 1IC
. PA ©, P - Ter -
N7 © RS e LP W 20.94
! w0 ZL-16 T \_03 ,l‘:‘-’ ] ’
- e \—}‘) o
3 | T \ 23.75
(ul i ' L T \ FAVES \
V8 e =T L 50.9
N \L_,:,‘L,\ ol \
—31. ) "\ 20 98
IC CL (2) BUILDING A

LR datatcl 4

Step 3 - Placing the Survey Point

e Hover your cursor over ARCHICAD's origin (0,0,0) as indicated as a black X on the
floor plan.

o Press X" on your keyboard and type in the desired coordinate. Based on the
Surveyors given coordinates above our X coordinate would be typed as 250978.895-
(coordinate value followed by minus sign “-")

e After the X coordinate has been entered press the tab key to drop down into the Y
coordinate and type in the desired coordinate. Based on the Surveyors given
coordinates above our Y coordinate would be typed as -386238688 (coordinate
value followed by minus sign “-“)

e Press the enter key and the Survey Point object will be placed at the entered
coordinates but in relation to the orientation angle as defined in Step 1.
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Step 4 - Coordinate examples

Image below shows the Survey Coordinate Object placed on Station Point A with the correct
coordinates as supplied by the Surveyor. (The Update Survey Coordinate objects command
again must be run in order to show the correct X/Y coordinates)

-250,078,895
386,239,688 IC C

0 ;7
\ 20.94

1
)
u
\
a
\

NT=

PEN

Image below shows the Survey Coordinate Object placed on Station Point B with the
correct coordinates as supplied by the Surveyor. (The Update Survey Coordinate objects
command must be run again in order to show the correct X/Y coordinates)

B

X: 250,986,919
IC CL IY: 386,272,885
Z:0

>
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